Shirt Pocket Discussions  
    Home netTunes launchTunes SuperDuper! Buy Now Support Discussions About Shirt Pocket    

Go Back   Shirt Pocket Discussions > SuperDuper! > General

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 02-05-2023, 01:57 PM
ctucker10 ctucker10 is offline
Registered User
 
Join Date: Oct 2008
Location: Savannah GA
Posts: 19
Schedules copies have intermittent problem

I have an issue with my scheduled copies. It sounds a lot like this post from Shirt Pocket Watch on Jan 12:

Quote:
v3.7.3 was released to correct two rare problems: both of which had to do with launching scheduled copies.

The first was a weird race condition that caused occasional crashes right at launch, but only with scheduled/scripted copies launched without loading settings. It was strange, we couldn't reproduce it internally, but it happened to a few users and we think we've run it down.
I think my setup is experiencing the "weird race condition" described above.

The instability began on Jan 23 when I updated from SuperDuper! Version 3.7 (126-0b1cb57) to SuperDuper! Version 3.7.5 (131-4cb66b9). At that time I was still using an M1 Mac-mini running macOS Ventura 13.1. Since then I've moved to an M2 Pro Mac mini running macOS Ventura 13.2 and the problem persists.

I've tried a couple of things to try to get to the bottom of it. So far I haven't found a solution.

- recreated scheduled copies
- uninstalled/reinstalled SuperDuper and all of its component pieces

Each time I test the setup, with an artificial scheduled copy time it works but, when I set the real scheduled time, which occurs in the middle of the night, I find that the copy was not successful when I check the following morning...occasionally.

I've watched the issue occur a couple of times:

- SD launches
- the destination/target disk mounts
- the copy operation crashes/does not successfully start
- SD quits
- the destination/target disk does NOT unmount (as it should)

I'd like to fallback to a previous version to see if this issue follows the version but, if anyone has a different suggestion I'm all ears.
Reply With Quote
  #2  
Old 02-05-2023, 03:07 PM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,879
Send a message via AIM to dnanian
If a copy is crashing, do you get a log? Please send me that via the support email.
__________________
--Dave Nanian
Reply With Quote
  #3  
Old 02-05-2023, 03:23 PM
ctucker10 ctucker10 is offline
Registered User
 
Join Date: Oct 2008
Location: Savannah GA
Posts: 19
I'll send the log the next time it happens.
Reply With Quote
  #4  
Old 03-09-2023, 06:04 PM
Estuary Estuary is offline
Registered User
 
Join Date: Jun 2008
Posts: 16
I've had a similar problem for awhile (I'd say 6 months or more): Every so often (now perhaps once every two weeks, on average), a scheduled copy won't run. There won't be an error message, so there's no log recording this, but if I open SD, I'll sometimes see that the "last copy" wasn't yesterday (I have it run every day around 3:30 AM). An additional problem is that once it doesn't run, it doesn't resume running the next day, and with no error message, it might be a week or more before I see it hasn't been backing up. I've taken to looking every day, but it shouldn't have to be this way. I cure the problem by selecting "Copy Now"; once it copies in this manual way, it will resume running on schedule (until the next time it stops copying). I had hoped the latest update would solve the problem, but unfortunately it hasn't.
Reply With Quote
  #5  
Old 03-09-2023, 08:47 PM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,879
Send a message via AIM to dnanian
Remember that we'll notify when we *do* back up, and you can make those sticky. So, you can readily see if something failed.

We always run if we're allowed to. If we're not running, your Mac is likely not waking as it should...
__________________
--Dave Nanian
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
System restore problem todivefor General 3 04-05-2020 09:49 PM
Mavericks 'Invalid' Start-Up Problem Loopy C General 13 10-11-2017 09:14 PM
How to clear/reset scheduled copies red errors? bkpr General 5 04-13-2015 07:02 AM
Scheduling problem todivefor General 3 10-26-2014 03:45 PM
SD no longer honouring backup-on-mounting-drive Manu Chao General 27 10-20-2013 04:58 PM


All times are GMT -4. The time now is 06:32 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.