Shirt Pocket Discussions  
    Home netTunes launchTunes SuperDuper! Buy Now Support Discussions About Shirt Pocket    

Go Back   Shirt Pocket Discussions > SuperDuper! > General

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 11-23-2008, 09:20 PM
agiabuba agiabuba is offline
Registered User
 
Join Date: Sep 2008
Posts: 11
SD oddities with new drive...

I've happily backed-up my drive for months on a MyBook Studio 500GB partitioned (unconsciously) with Apple partition map...
I recently bought the same external drive, a MyBook Studio but with 1TB drive, to substitute my "old" one...
(I didn't know it wasn't recommended, anyway I never had troubles with the previous one)

when I was about to partition it I discovered the APM vs GUID thing, and after a fast search here I decided to partition it using GUID partition table (I'm on an intel Macbook Pro running Leopard 10.5.5)

the drive, as I did with the old one, has two partitions: one for archiving purpose, and one where I backup my internal drive.

NOW, since I'm using the new drive (I can't try with the old one because I don't own it anymore) I regularly have two "errors":
-SD can't find the target volume. It appears that SD keeps searching for the old partition, even if I already performed several backups on the new drive (the name of the new backup partition is different from the old one). --> see down
-SD prevent the system to shut down: the option "on succesful completion - shut down computer" that always worked as it should, lately fails to work... SD doesn't display any error, but the system doesn't shutdown and alerts that SD app impeded the shut down etc.

any idea on what's goin' on?
thanks, agiabuba

PS: I already tried to both delete SD preferences for the first error, and to login holding SHIFT for the second thing, but nothing changed...
edit: after I deleted the preferences AND rebooted now SD seem to recognize the target drive properly... I'll check again after the next backup!
Reply With Quote
  #2  
Old 11-26-2008, 01:59 PM
agiabuba agiabuba is offline
Registered User
 
Join Date: Sep 2008
Posts: 11
okay, with the last backup I verified that the target volume is now recognized properly, the only problem is that OSX is still unable to shutdown the computer, how can this be related with the hard drive? any hint David?

here a screenie after the backup:


the text is in italian, but it basically says the classic error:
Quote:
Logout has timed out because the application SuperDuper! could not be quit. To try again, quit Finder and choose Log Out from the Apple menu. You can use the Force Quite menu item in the Apple menu (or press Command+Option+Esc) to quit an unresponsive application
???
Reply With Quote
  #3  
Old 11-26-2008, 02:08 PM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,827
Send a message via AIM to dnanian
Quit SD! and try removing the "Saved Settings" folder in Library/Application Support/SuperDuper!, then run again and let's see if it helps.
__________________
--Dave Nanian
Reply With Quote
  #4  
Old 11-28-2008, 02:12 AM
agiabuba agiabuba is offline
Registered User
 
Join Date: Sep 2008
Posts: 11
did, sadly Leopard failed to shutdown again...

how SD! handles the shutdown? it uses native OS commands?
Reply With Quote
  #5  
Old 11-28-2008, 08:49 AM
RonaldPR RonaldPR is offline
Registered User
 
Join Date: Jun 2008
Location: Amsterdam, Netherlands
Posts: 25
An error in the translation of the error message above:
"To try again, quit Finder and choose Log Out from the Apple menu."
should be:
"To try again, quit SuperDuper! and choose Log Out from the Apple menu."

This looks very similar to the problem in this thread: http://www.shirt-pocket.com/forums/s...ead.php?t=2706 where shut down would not happen because SD! could not be quit.

On my machine that problem started with Leopard and mysteriously resolved itself after a couple of months. Possibly (but I am not certain) the problem had gone after a 10.5.x full Combo-update.
Reply With Quote
  #6  
Old 11-28-2008, 09:08 AM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,827
Send a message via AIM to dnanian
We use standard methods to ask (not demand) Finder to tell the system to shut down -- as Ronald mentioned, some people do have a failure when this happens, but we've never been able to reproduce that problem in house, and it seems to be intermittent even for those it does happen to...
__________________
--Dave Nanian
Reply With Quote
  #7  
Old 11-30-2008, 10:45 PM
agiabuba agiabuba is offline
Registered User
 
Join Date: Sep 2008
Posts: 11
I really have no idea...
the problem appeared with the new drive, but this could depend on several other things... not least the switch from APM to GUID

let's see after 10.5.6, that seem to be on the doorstep

Last edited by agiabuba; 12-01-2008 at 03:01 AM.
Reply With Quote
  #8  
Old 12-01-2008, 03:02 AM
agiabuba agiabuba is offline
Registered User
 
Join Date: Sep 2008
Posts: 11
yeah!! I finally figured it out...

in fact I still have no idea of what exactly happened, but seeing that nothing else would have worked I tried to delete some caches with Onyx and... it worked

thanks a million dave!!
Reply With Quote
  #9  
Old 12-01-2008, 07:41 AM
RonaldPR RonaldPR is offline
Registered User
 
Join Date: Jun 2008
Location: Amsterdam, Netherlands
Posts: 25
I routinely run applejack before a system (or system-related) update. That includes deleting most system caches. It took a while before applejack was updated to be compatible with Leopard and it is possible that the problem was solved after the first time I did again a system update with running applejack first.
Reply With Quote
  #10  
Old 12-01-2008, 08:18 AM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,827
Send a message via AIM to dnanian
Cache deletion, eh? Anyone else with this problem find that helps?
__________________
--Dave Nanian
Reply With Quote
  #11  
Old 01-11-2009, 05:36 PM
agiabuba agiabuba is offline
Registered User
 
Join Date: Sep 2008
Posts: 11
hi dave, I recently had the same problem again, and solved it in the same way:

I had to backup my internal drive (say disk1) on a friend's external drive (disk3) different from the one I use for daily backup (disk2)...

so I backed up disk1 to disk3 using "erase than copy" and everything was okay..

when, some days later, I plugged again disk2 SD! said it couldn't find disk3...
I selected disk2 and launched the backup with "shutdown" option, and it FAILED to shutdown at the end of the backup...

as the first time, everything was solved with Onyx cache deletion.


I can't try now becouse I'm really busy, but I think the steps to reproduce the problem could be the followings:

plug a (firewire) drive > launch SD! and "backup, all files" on it with "erase than copy" > restart (dunno exactly, about week was passed in the meantime) > plug a different (firewire) drive with a different name > launch SD! (it will tell you that can't find the first drive) > select the second drive from the dropdown and perform a full backup with shutdown option...

if the Finder fails to shutdown the computer as I expect, try to delete caches (dunno what kind of cache does the job, in Onyx "automate" panel I selected both system & user caches)

really hope this helps finding out the problem
Reply With Quote
  #12  
Old 01-11-2009, 06:06 PM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,827
Send a message via AIM to dnanian
I'll try, agiabuba.
__________________
--Dave Nanian
Reply With Quote
  #13  
Old 01-11-2009, 06:09 PM
agiabuba agiabuba is offline
Registered User
 
Join Date: Sep 2008
Posts: 11
yep, just ask if you need any detail and I'll try to remember
Reply With Quote
  #14  
Old 04-01-2009, 08:12 PM
agiabuba agiabuba is offline
Registered User
 
Join Date: Sep 2008
Posts: 11
hello Dave, any news on this topic?
I didn't write again, but I still have the problem from time to time, and often deleting caches isn't enough (I also need to delete SD preferences - that's quite annoying!)

yesterday SD! failed again to shut down the machine, here's what I found in Console.app:

Code:
31/03/09 00:57:20 SuperDuper![652] .scriptSuite warning for attribute 'boundsAsQDRect' of class 'NSWindow' in suite 'NSCoreSuite': 'NSData<QDRect>' is not a valid type name. 

31/03/09 00:57:20 SuperDuper![652] .scriptSuite warning for type 'NSTextStorage' attribute 'name' of class 'NSApplication' in suite 'NSCoreSuite': AppleScript name references may not work for this property because its type is not NSString-derived. 

31/03/09 00:57:20 SuperDuper![652] .scriptSuite warning for type 'NSTextStorage' attribute 'lastComponentOfFileName' of class 'NSDocument' in suite 'NSCoreSuite': AppleScript name references may not work for this property because its type is not NSString-derived. 

31/03/09 00:57:20 SuperDuper![652] .scriptSuite warning for attribute 'boundsAsQDRect' of class 'NSWindow' in suite 'NSCoreSuite': 'NSData<QDRect>' is not a valid type name. 

31/03/09 00:57:20 SuperDuper![652] .scriptSuite warning for type 'NSTextStorage' attribute 'title' of class 'NSWindow' in suite 'NSCoreSuite': AppleScript name references may not work for this property because its type is not NSString-derived. 

31/03/09 00:57:20 SuperDuper![652] .scriptSuite warning for superclass of class 'NSAttachmentTextStorage' in suite 'NSTextSuite': 'NSString' is not a valid class name. 

31/03/09 00:57:20 [0x0-0x35035].com.blacey.SuperDuper![652] crontab: no crontab for MacBookLo
could this be of any help?
Reply With Quote
  #15  
Old 04-01-2009, 08:45 PM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,827
Send a message via AIM to dnanian
Those are normal and will happen every time you start up.

Another user (actually, you) indicated that using Cocktail/Onyx to delete your user and system caches might help with the shutdown problem.
__________________
--Dave Nanian
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Windows equivalent to SuperDuper!? jreffner General 21 08-13-2009 05:36 PM
Migrating from one hard drive to another zestyping General 3 07-25-2008 08:22 AM
MacBook Pro Drive with Boot Camp to boot into Vista scottsdale General 1 06-11-2008 08:09 AM
Best process to replace internal hard drive using SuperDuper!? emikysa General 26 02-09-2007 05:03 PM
Long Hang While Copying BackerUpper General 4 06-12-2006 08:26 AM


All times are GMT -4. The time now is 02:13 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.