Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   Mount remote disk (

nickair 01-25-2006 06:25 PM

Mount remote disk
I would like to schedule backups on a remote server.
For that I thought about writing an AppleScript that would be executed before the backup. It would mount the remote disk (mount afp://, execute the backup, and then execute another script to unmount the remote disk.

The problem is that when I connect to the remote disk, I have to click on the "connect" button which will interrupt the connect procedure.

How can I do to automate to complete scheduled backup procedure?



dnanian 01-25-2006 08:19 PM

Well, if you place the image -- using SD's "Disk Image..." choice in the destination po-up -- on the remote machine, and tell the system to add the password to keychain, it should mount automatically, without clicking "Connect". That'd be how I'd do it.

nickair 01-25-2006 08:47 PM

Unfortunately it fails to mount the destination image

dnanian 01-25-2006 09:03 PM

But does it mount the remote volume? If so, what error do you get when it fails to mount the destination? Could it be a permission problem on the remote side?

nickair 01-26-2006 05:37 AM

Yes there was a permission problem. I fixed it but it still fails to mount the remote volume. I get this error in the log:

| 11:34:00 AM | Info | ...ACTION: Mounting Backup - Titan
| 11:34:00 AM | Info | ......COMMAND => Preparing Backup - Titan
| 11:34:02 AM | Info | hdiutil: create failed - No such file or directory
| 11:34:02 AM | Error | ****FAILED****: result=256 errno=0 (Unknown error: 0)


dnanian 01-26-2006 11:58 AM

OK: that indicates that the destination of the backup isn't mounted, indeed. But it won't mount it if SD! is running and you click "Copy Now". The mount is part of an alias dereference that happens when settings are loaded (which is also what happens when you start SD!). So -- try to set things up the way you want. Then, quit. Restart SD! and it'll restore the source and destination, and *that* will mount the remote volume. If it prompts for your password, make sure you add things to the keychain.

nickair 01-26-2006 07:49 PM

Ok Dave. Thanks for your answer.
I'm making a new backup over the network now. By the way, it has been running for almost 5 hours now and has only completed 15.5Gb (out of 38). Is that normal it's so slow?
Anyway, if it succedes to complete this backup, I hope it will solve my problem ;)

I'll post the results here when it's finished.

Thanks again!

dnanian 01-26-2006 07:54 PM

This is over a WAN, Nick? It doesn't surprise me hugely that it would be slow, especially the first time...

nickair 01-26-2006 08:04 PM

No, it's over a LAN. I just made the calculation. I guess it sould take about 8.5 hours on a 10Mb/s LAN... Hmm... Why can't SD! use a sparse image that wasn't created over a network, but which already exists on a remote destination? It's not possible to choses an existing image or have I missed something?

dnanian 01-26-2006 08:08 PM

It can, actually. While the image is "grey" you can still select it. Ignore the "overwrite" warning, and we can use it without any problem.

nickair 01-27-2006 06:21 AM

So the backup is now finished. It worked fine. So I scheduled an automatic backup, which started automatically, but it failed, because it couldn't mount the remote volume... What am I doing wrong?

dnanian 01-27-2006 08:09 AM

Which mount failed? The image or the remote volume?

nickair 01-27-2006 09:05 AM

Actually it's the remote volume that doesn't mount. If it's already mounted, the image mounts fine.
I have some news though. When I open SD!, it automatically connects to and mounts the remote volume.
If it runs a scheduled backup, the remote volume doesn't mount...

dnanian 01-27-2006 09:09 AM

That's strange, because a scheduled item launches SD and resolves the same alias that should do the mount.

Was the schedule starting SD from the "quit" state? What happens if you double-click the scheduled settings in ~/Library/Application Support/SuperDuper!/Scheduled Copies, with SuperDuper not running?

nickair 01-27-2006 09:28 AM

If I double-click that file, it opens SD! but the remote volume still doesn't appear...

All times are GMT -4. The time now is 03:26 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.