Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   New User; Problems. (

Canoe112 01-01-2005 04:34 PM

New User; Problems.
I just purchased a copy of SuperDuper.

I have two problem areas.

1. I created a script to use for back up to a flash drive. I want to only copy current documents and selected user library folders and files. The script is:

Copy users/xxx/documents

Copy users/xxx/library/keychains

Copy users/xxx/library/mail

Copy users/xxx/library/preferences

I do not want to clone or copy any other files.

I created a name for the script and it shows in the "What's Going To Happen" dialog box. The script is named xxx Backup.dset

When I started copying, SuperDuper tried to clone or copy the entire hard drive. The Flash Drive filled up before SuperDuper copied the actual files I want copied.

What am I doing wrong with the set up that is creating this problem?

2. I deleted the unwanted files from the Flash Drive in the hope of running the script file again.

Now my OSX 10.3.7 computer will not even recognize the Flash Drive. This problem occurred immediately after using SuperDuper.

Did SuperDuper create this problem?

Does anyone have any idea how to get my computer to recognize the Flash Drive as it did previously?



Canoe112 01-01-2005 06:09 PM

Additional Problem
There appears to be one additional problem:

3. I have installed a new out of the box SanDisk Titanium Flash Drive. My OS recognizes the Flash Drive and it shows on the Desk Top. However, the Flash Drive is not recognized by SuperDuper. The only drives that show in SuperDuper are the HD and the .dmg file.

How do I get SuperDuper to recognize both the old and the new Flash Drive?



Canoe112 01-01-2005 06:44 PM

I was able to access the drive using Disk Utility and reformatted it. The B Tree Node was corrupted.

Problem #3 is solve.

Please advise regarding #1 and #2 above.



dnanian 01-01-2005 09:26 PM

Hi, "Canoe" -- thanks for your registration!

The first problem is pretty easy: take a look at the FAQ entry here, which should answer your question -- basically, since the default is to copy everything, adding "additional" folders doesn't exclude anything. You have to ignore "*" and ".*" first.

The second isn't anything I've seen before: I can't see how SD!, by just copying files to a drive using system calls (which is what we're doing), can make the drive unrecognizable by the system... can you see it with Disk Utility?

dnanian 01-01-2005 09:37 PM

The problem here is also covered in a FAQ entry -- flash drives (and some hard disks) are shipped formatted as FAT32 devices, and as such can't be used as a clone destination because they can't retain all the metadata properly (and can't be used as a boot target). Reformatting it as HFS+ will allow it to show up.

Canoe112 01-01-2005 10:47 PM


Thanks, for getting back to me on this.

I will review that FAQ, sounds like it will work.

One additional issue has come up.

When I got SuperDuper I intended to be able to shoot identical back ups to two different Flash Drives. This way I can keep one back up with me and also have another back up in my drawer if I lose the Flash and Computer I travel with.

I wanted to use "smart update" because of the speed of back up.

But, SuperDuper will only recognize the first Flash Drive I have used and not also the second Flash Drive.

Is this a limitation of the program or is it something I set up incorrectly?

Do you know any way for me to back up to two different Flash Drives.



Canoe112 01-01-2005 11:33 PM

The commands:

ignore *

ignore .*

worked fine and files from documents started to be copied.

However, only files under:


were copied.

The following were not copied:


user/xxx/documents/appleworks user data/*.*

user/xxx/documents/microsoft user data/*.*




All commands are as stated in the first post with the addition of the two "ignore" commands you recommended.

I am having a hard time understanding why I get this result.

Do you have any input?



dnanian 01-02-2005 05:30 AM

I can't think of any reason why SuperDuper! would only recognize one of the two flash drives. Perhaps it's prompting for the first one because those settings are saved automatically... you need to cancel and insert the 2nd drive (which has to be formatted for HFS+). Try naming both differently to ensure you have the proper drive inserted... this should work fine (we don't even know it's a flash drive).

dnanian 01-02-2005 05:32 AM

Well, I think you want:

Users/xxx/Documents/Microsoft User Data

(leave off the *.*, and things are case-sensitive)

Note that if you have multiple users, you can substitute "*" for xxx, above, e.g.


(or whatever)

Canoe112 01-02-2005 06:55 PM


You were correct about why the Flash Drive was not recognized. The Flash was not in the correct format. That has been fixed and SD! now recognizes both drives.

The script commands I used did not include the *.* notation. I used the commands included in the SD! script tool. I merely used the *.* notation when posting to you to identfy that it was all files that were missing.

I fixed the problem by deleting the old script and making a new script. For reasons I don't understand this fixed the issue.

I have one remaining open issue. One Flash Drive works fine for Backup. The second drive appears to go through the entire backup process properly. But when I look at the drive in Finder no files are shown. However, the MB used appear to show that the correct files have been copied.

I have reformatted this drive twice and always get the same result.

Why would the backed up files not show on this second drive?



Canoe112 01-02-2005 07:06 PM


You can ignore the last post.

The problem is a defect in my OS 10.3.7. Once I eject the Flash Drive and reinstall it, all files show.

SD! works fine and is much cleaner than the highly touted Retrospect.

I will definitely recommend SuperDuper! over Retrospective on the Apple Boards.

For future versions you may wish to consider encryption and compression abilities.

Thanks for the product and tech support over the holidays.



dnanian 01-02-2005 09:54 PM

Beat me to it while I was traveling, Hal!

Yeah -- the issue is that Finder doesn't always show files that are copied "behind its back", but the files are definitely there... you can also restart the Finder (Option-Control-Click the Finder icon in the dock) to get the files to show up.

Thank you for the kind words -- definitely let people know about SuperDuper! -- the more the merrier!

Canoe112 01-09-2005 08:22 PM


I have been using SuperDuper! for my backups to the Flash Drives.

It is working flawlessly.

Thanks for a clean, elegant and stable program.


dnanian 01-09-2005 09:50 PM

Great to hear, Hal! Check us out at Macworld if you're there...

All times are GMT -4. The time now is 10:52 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.