Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   Leopard backup boots, but apps crash? Try this. (

dnanian 04-19-2008 04:56 PM

Yes, make a new backup and run the script at the end of the backup. Don't do this from the backup itself.

jeffhands 05-23-2008 07:33 PM

need some more instruction...

I downloaded your zip file and unzipped it.

In the past I thought of myself as a power user, but now since OS-X, there's a lot "under the hood" that's unclear to me.
For example, I have never used Terminal and am reluctant to do so unless I have really detailed instructions.

What do I do with this "" file? I can see that it is a text file.
Is it something that I paste into Terminal, if so, where and how? Or what do I do?

My MacBook is at the local Apple repair; where they determined that it needs a new motherboard, so I don't have the original hard drive in my hands.

Can I implement this fix when I have booted from the cloned drive? Or do I need to get the MacBook back and use this fix before creating a new clone?

As you can see, :confused: I am bordering on clueless. ;)

Thanks for the help.

Jeff Hands

dnanian 05-24-2008 11:19 AM

You don't have to use Terminal: the instructions I provided in the first post explains what to do. But if your Mac is already at the shop, it's a little too late to implement this particular fix.

Are you running from the copy now?

jeffhands 05-26-2008 10:34 AM

not running from the clone right now
Thanks for the quick response.

Forgive me for being dense, but as I look at the instructions from the first post I can only understand the first point:

"To use it, do the following:

1. Unzip the attached to a convenient location (not your Desktop - I recommend an "Applications" folder in your Home folder).

:) OK, that I understand... but :confused:

2. Set the "" script that gets unzipped a the "After copy" script in the Advanced tab of Options.

:confused: Sorry this second step is utterly Greek to me.

How do I ... "set a script" ? Is Super Duper already open when I do this? Is the Advanced tab of Options in Super Duper?

When I get the MacBook back again on Friday I'll try this all over again, because I do want to have a usable clone always on hand.

Thanks again.

dnanian 05-26-2008 11:40 AM


- Open SuperDuper!
- Click "Options"
- Click the "Advanced" tab
- Check the "After copy" option checkbox, and choose the "" file as the script to run.

Hopefully that'll help.

jeffhands 05-31-2008 09:27 AM

that's what I needed!
Thanks for the extra explanation!
That was just what I needed. I made a new clone, after getting my MacBook back and the clone works just fine. What a relief!


limsilas 06-06-2008 12:32 AM

do i have to run this script after every backup?
script worked like a charm after i ran it: all my apps on my clone now actually work.

but do i need to continue to run this script after every backup?

as a side note, my applications only started failing once i switched backup drives. it also prevented carbon copy cloner clone applications from running as well...

what exactly does the script do? does it fix pre-binding on the clone or the "home" system? i know utilities like onyx fix pre-binding...

dnanian 06-06-2008 08:36 AM

Until our next update comes out, you do need to run the script after every copy (which is why you set it as the 'after copy' script -- it'll happen automatically.

It fixes prebinding on the copy, not on the home system.

limsilas 06-06-2008 11:15 AM

hi david,

i'm curious as to why this is happening now when it did not occur about a month ago, and the only variable that has changed is my external drive?

also, would it be possible to fix the pre-binding on my home system, and have that "fixed pre-binding" transfer over onto the clone, thus eliminating need for the script?

i don't mind running the script after each clone; i'm mainly curious as to why this is occurring in the first place.

dnanian 06-06-2008 11:26 AM

I don't know why it's suddenly started happening: it doesn't happen to me, and hasn't happened on any of my test systems. It's clearly some unusual change in Leopard, but I don't know what it might be -- I only know that re-prebinding on the destination resolves the issue.

No, fixing the prebinding on the source doesn't do it, unfortunately. It has to be done post-copy, on the destination.

limsilas 06-06-2008 06:01 PM

oh, i remember what's changed on my end since last superduper-ing: 10.5.3.

anyone have this issue in 10.5.2?

dnanian 06-06-2008 06:03 PM

Yes, nearly all of the thread -- above -- is pre-10.5.3.

Clerkhaw 06-19-2008 07:31 AM

Hi there...

Some things are a little cloudy to mee.

See my situation:

1.I've made a disk image backup into a external drive.
2.Booted with Mac OS 10.5.1 Leopard DVD and put Disk Utility to work.
3. Selected Open->Image and then selected the backup image on my external drive.
4. Mounted the backup image on external drive
5. Selected it as source and then erased my local Hard Drive
6. Told disk Utility to clone

After I booted up, nothing is running with exception of Opera, neither Firefox, Safare, Activity Monitor, Terminal, even superduper.

How can this script be applied to my case?

Thanks a lot!

I'm really desperate here, just cant work right now.

dnanian 06-19-2008 08:31 AM

Please download (using Opera) Onyx and use it to rebuild your prebindings. That should fix the problem.

Clerkhaw 06-19-2008 08:50 AM

Hi dnanian,

Onyx is crashing too, simple can't open it.

I've tried to create a new account to run Onyx and it's was okay, I runned your script too as root and nothing...

I could simple use this new user as you can see now (just figure it out) but I have sooo many things on this account, so many preferences for tons os things, is there an easy way to import all that?

Thanks for your reply.

All times are GMT -4. The time now is 08:14 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.