Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   SuperDuper prevents MacBook Pro from sleeping (

scotty321 06-14-2008 04:49 PM

SuperDuper prevents MacBook Pro from sleeping
Hello there,

We've noticed a recurring problem with SuperDuper and Mac OS X 10.5.x that we were not experiencing in 10.4.x. We're currently running SuperDuper 2.5 (v84) on a MacBook Pro running 10.5.3. This problem happened in 10.5.2 as well.

Once we run SuperDuper once, our MacBook Pro never sleeps again on its own (based on the sleep setting that we've set in the energy saver system preference), even after quitting out of SuperDuper. We have to restart our computer to get our machine to sleep on its own again.

What's been going on is this:

We manually launch SuperDuper so that it can perform a smart update of our internal drive ("Macintosh HD") to an external USB LaCie Rugged Drive ("Scott's Rugged Drive") that we manually plug in specifically for the purposes of making a SuperDuper clone. We manually start the smart update on our own (no schedules are set at all).

These are the General Options that we've set:
1. Repair permissions on Macintosh HD.
2. Smart Update Scott's Rugged Drive from Macintosh HD.
3. On successful completion, Do Nothing.

These are the Advanced Options that are set:
1. During copy, copy ACLs from Macintosh HD.

After the copy is complete, the computer will no longer sleep on its own through the settings that we've specified in the energy saver system preference setting. Even after quitting out of SuperDuper and disconnecting the USB drive. However, the MacBook Pro WILL successfully sleep when we MANUALLY tell the machine to sleep (by pulling down from the Apple Menu to "Sleep", or by closing the lid), but it will not sleep on its own.

After restarting the machine, things are okay again and it will sleep on its own again.

Any ideas on how to fix this problem?


chris_johnsen 06-14-2008 07:09 PM

No help here, but I think I have had this same problem on 10.4. I was never able to definitively pin it to having made a backup with SuperDuper! (I only do backups once a week, and have never bothered to keep records of reboots, SD! runs and otherwise unattributable failures to auto-sleep).

My setup:
Weekly "all files" backup using Smart Update.
iBook G4
External Lacie USB disk (Porsche) that is not normally connected; partitioned into 2 system backup partitions and one data partition.
I do not repair permissions and I do not copy ACLs.
After backup: run a script that does mdutil -i off to disable Spotlight indexing on the target volume (put in place before SD! did this itself, I think).

When the problem happens, the machine will not automatically sleep, but will sleep when I select it after pressing the power button, after selecting it from the Apple menu, or after pressing Command-Option-Eject. Rebooting restores auto-sleeping.

Since I cannot offer any firm evidence that SuperDuper! is involved (even peripherally, i.e. something to do with the drive that I have SD! using), feel free to just treat this as anecdotal.

dnanian 06-14-2008 07:40 PM

Scott & Chris:

I can't think of anything in SuperDuper! that -- once we're done copying -- would prevent sleep in any way. We do a lot of I/O, obviously, when we run -- and while we're copying, we do respond, when asked by the system if it's OK to sleep, "not right now".

But that's a question every program is asked, and once the copy is over, we no longer refuse (and obviously, once we're not running, we can't do anything).

So... I can only suggest that, for whatever reason, heavy I/O is preventing your sleep, or some other program, and SD! is peripherally involved simply by doing the I/O.

All times are GMT -4. The time now is 02:40 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.