Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   Sierra To High Sierra Update Failed: Here Are The Details. . . (

Mojo 07-04-2019 01:07 PM

Sierra To High Sierra Update Failed: Here Are The Details. . .
Yesterday I upgraded my wife's 2011 13" MBP. *It has a Samsung SSD 850 EVO that replaced the original internal drive.

The upgrade appeared to be fine yesterday but upon startup this morning a log window appeared with a notice that the High Sierra upgrade was incomplete or failed. *It suggested reinstalling High Sierra.

Fortunately, I made a bootable backup of the MBP using SuperDuper on an external hard drive prior to doing the upgrade. *The MBP is now booted-up using the external. *When I tried to selected the "Macintosh HD" as the destination for High Sierra it was greyed-out. *It read:

Disk not formatted as Mac OS Extended (Journaled). Use Disk Utility to enable journaling or reformat the disk."

For kicks I tried running First Aid Repair on the Macintosh HD but it failed.

Now here is where it gets interesting. . . In Disk Utility the internal drive at the top reads "AppleAPFSMedia." *The volumes listed under it read "Macintosh HD, Preboot, Recovery and VM. * Then there is a second internal drive labeled "Samsung SSD 850 EVO 250GB Media."

Why two internal drives are showing is a mystery to me. . . And I have no idea how to proceed from here. *Am I glad that I backed-up the MBP before doing the upgrade! *(I also made a copy of the backup this morning Just In Case.)

On Tuesday I upgraded my Mac Mini to High Sierra that boots from an external Samsung 850 EVO. Everything is running normally, so this problem caught me off guard. *It's the first OS upgrade failure in 24 years using Macs.

dnanian 07-04-2019 01:21 PM

You need to clean install the OS on the internal drive (erase, install). APFS is the new file system.

When it's fully installed, during first boot, it's going to prompt you to restore. Point at the SuperDuper backup and it'll bring in your applications and data.

(Your backup has an old version of the OS that doesn't know about APFS.)

Mojo 07-04-2019 01:40 PM

Hi Dave- Which internal drive? The Macintosh HD is greyed out in the installer.

I listed the volumes displayed in Disk Utility above. Note that there is only one internal drive in the MBP.

AppleAPFS Media only has First Aid, Erase, Restore and Info available.
Samsung SSD 850: Partition is added to the options.

Once I know which one to select. I then erase it via Disk Utility, then run the installer?

dnanian 07-04-2019 02:17 PM

It sounds like you're not installing the "most recent" version of the OS. See this Apple KB article:

Mojo 07-05-2019 02:42 PM

That last info appears to have done the trick. . . The part about the earlier OS not being aware of the existence of APFS was not lodged firmly in my skullbank. It's a New Era Mac-wise and I need to update my knowledge accordingly.

Many thanks for your help; I didn't expect a response on July 4th. But you have always had the speediest customer support that I have experienced in 24 years using Macs, so I guess that I shouldn't have been surprised. :)

dnanian 07-05-2019 03:58 PM

Glad I could help.

All times are GMT -4. The time now is 03:23 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.