Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   Apple Software Update problem after using SuperDuper (

ctolgc 01-28-2004 10:57 AM

Apple Software Update problem after using SuperDuper
I used SD to clone my OS X boot drive to a larger second internal drive. Everything worked great, and I seem to have proper access to all of my documents and applications. I have found, however, that I cannot use Apple's Software Update feature. I receive an error which states that I need to have permission to write to


I have tried to use Disk Utility to repair permissions, but the error persists. I have manually downloaded the 1-26-2004 Security Update and the installer runs, but it tells me that my new boot volume does not meet the requirements for the update. Is it possible that some invisible files did not copy properly to the new drive?

dnanian 01-28-2004 11:41 AM

Hi -- thanks for getting in touch!

This isn't something we've ever encountered before in our testing, so I'm going to need a bit more information from you to try to either duplicate or diagnose the situation at my end.

(Note that I've done hundreds of full-volume clones over the past year or so, and haven't ever seen this problem -- which isn't intended to excuse the issue, but rather to say that something unexpected was encountered, and we'll do our best to get you back on track ASAP.)

First: is there anything "unusual" about your system or disk configuration? Are you using anything strange like NFS mount points, an isolated Users volume, NetBoot or the like?

Second: what copy script did you use to create the duplicate volume? Did you modify it at all?

What's unusual here is that we exclude the /tmp directory tree (actually /private/var/tmp) when a full clone is made -- so that tree was recreated by the system after you rebooted... very strange that you wouldn't be able to write into something that was just created.

Are you comfortable using the Terminal? If so, could you send me a listing of /tmp/501/Temporary Items, using the command:

ls -ln /tmp/501/Temporary\ Items

and another of:

ls -ln /tmp/501/Temporary\ Items/

That'll help me try to see what might be happening.

Thanks very much for your patience while we try to figure out what went wrong here.

If you have the time, and you're in the US, send me some mail to with your name and phone number and I'll follow up on the telephone, at my expense. That might speed things along.

For anyone reading along, I'll summarize the result here.

ctolgc 01-28-2004 02:47 PM

Problem fixed

Thanks for the extremely fast response to my earlier post. I managed to track down the problem. In my extreme caution cloning my boot drive to a second larger drive I had first backed up my home directory and buried it in a folder on the second drive. When I cloned my original disk to the second drive, I used the backup-all files script and had set the options to allow other files on the second drive. By doing this I had two copies of my home directory. One in the users folder and one buried in the second folder from a manual backup. Once the second home directory was deleted Software Update worked fine. SuperDuper! was super perfect at allowing me to move to a larger drive! Thanks for making great software for the Mac!:)

dnanian 01-28-2004 02:54 PM

Thanks for the followup, ctolgc. We were pretty stumped here as to how that could have happened.

I'm still not entirely sure I understand why a second copy of your Users folder, buried elsewhere, would cause Software Update to fail the way it did. I'm going to have to try to replicate the situation here to see if I can get it to occur, and to make some kind of sense. What was the name of the "buried" directory? Were there any other files on the drive when you initially cloned it?

Now that you've cloned over, take a look at the Safety Clone feature of SuperDuper! It's a pretty great way to ensure that bad things don't happen to your working system in the future.

Thanks very much once again for the follow-up, and thanks for using SuperDuper!

ctolgc 01-28-2004 04:03 PM

More Information

I had several files on my second drive at the time of the cloning. Initially, I was just going to Backup-All Files from the smaller drive to the larger drive. I read that I was about to erase the second drive in this process. I was able to change this using the options button. Prior to the move, I created a new folder called Drive 2 on this drive. The drive itself was called Macintosh HD 2. I moved all to the files at the root level of this drive into the Drive 2 folder. I also manually dragged my home directory from the Users folder of my boot drive to create a backup prior to cloning. I did not want to lose any documents or lose the ability to open any docuements if something went wrong. I set the options to allow files on the target disk and ran the Backup-All Files with SuperDuper! I took the dog for a walk and came back to find everything working perfectly! All of my files were perfect. Today, I ran Software Update knowing that Apple had released a security update as well as an Airport update. The Software Update application asked me to authenticate with name and password, then delivered the error message concerning permissions for I ran Disk Utility to repair permissions. The update still reported the same error. I tried restarting the computer. Same error. I used Find to search for setting it to search for both visible and invisible files. It found the file in 3 locations. One was in username:library:caches:, the second was in harddrive:library;caches:, and the third was in harddrive:drive 2(the folder I had created):users:username:library:caches. When I saw the drive 2 directory reference I thought it might be interferring with software update. I deleted the users folder (my backup copy) from the drive 2 folder and software update ran fine. I am certain that I had run software update after using SuperDuper!, but this is the first time any new software had been available to install. Thanks again for your prompt and thorough assistance.

dnanian 01-28-2004 04:32 PM

Thanks for the additional details -- that helps a lot.

Again -- glad it's working now that you've figured out what the deal was!

All times are GMT -4. The time now is 12:01 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.