Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   Cloned Drive Missing Kext Files (

abpanman 09-26-2008 11:38 AM

Cloned Drive Missing Kext Files
I needed a bigger hard drive for my iMac G5 so I cloned the existing internal drive onto a new Seagate 500GB. Thinking I had a perfect clone I then replaced the internal drive with the new Seagate drive. It boots up okay but several messages are displayed that some system extension .kext files are missing. Included in these are IOUSB.kext, unsupported.kext, and several others. Now my external drives are not recognized and won't mount. I think I'm going to put the original drive back in for now. Question is why didn't the .kext files get installed on the new drive?


dnanian 09-26-2008 11:47 AM

That doesn't make a lot of sense; it sounds like the initial copy failed, or the drive was damaged in a way that caused them not to be listed, since we do not skip those kexts.

abpanman 09-26-2008 02:57 PM

That's what I thought. When I get time I'm going to clone the original drive to the new one again and see if I get the same issue.


dnanian 09-26-2008 03:30 PM

Make sure the kexts are actually on the source, too: the kextcache might actually 'mask' the underlying problem.

abpanman 09-30-2008 09:04 AM

I did another clone to the 500 GB drive and all the kext files were there. I was able to swap it into the iMac and it works great. I guess the first clone must not have completed successfully. All is well now.

dnanian 09-30-2008 09:05 AM

Glad you're all set.

BigJim 08-12-2009 06:52 PM

More problems with *.kext files
I had a similar problem (wanting to clone my 250GB HD to a 1TB, then place the larger drive in the enclosure). I DON'T have a firewire, so the cloner took 6 hours to do the deed via my Mac's USB 2.0 port, which yielded about a half-dozen messages stating that *.kext files were "not installed, or installed improperly" messages.

I tried to visit this forum to see what others were saying about it, but the PPP.kext file was one of the missing ones, and I was unable to establish an Inet connection (yes, Virginia, I am still using a stinking dial-up connectivity "solution").

Since I am a Power PC, iMac G5, Leopard OS (v10.5.6) and do have the Time Machine, I decided to try restoring the *.kext files from backup. I guess I did succeed in restoring them, but then I was unable to boot up at all .. just stopped at the gray Apple screen, with the gear screwing around .. until the thing heated up so badly that the fan turned on, and I killed it .. tried this several times.

I inserted the original OS distribution CD, to invoke the Disk Utility .. everything was copescetic: nothing to repair.

I put the original HD back in - works fine - and am awaiting some online suggs to see if I can overcome this debacle.

dnanian 08-12-2009 07:01 PM

I have no idea what might have happened here (although using a USB drive with a Power PC macs is a mistake): it really sounds like you might have also had a damaged volume where either the kexts were not being listed or something was preventing them from listing.

(Your report, and the other in this thread, are the only times I've heard of this problem, so it's rather weird.)

I'd suggest an archive-and-install -- not a repair -- with your Leopard DVD.

BigJim 08-12-2009 08:33 PM

Missing *.kext files - going to retry
I did manage to overlook the sugg to shut down all other programs/processes before the cloning attempt. I didn't have anything else running, but during the 6-hour cloning, I imagine Time Machine cranked up a half-dozen times.

I'm going to shut Time Machine down the next time I try. Yes, the old USB2.0 port is a sloooow way to copy 250GB, and I let it crank overnight, but is the end result likely to be corrupted .. ie, yes it's slow, but is it also dangerous?

BTW, the SuperDooper! I have is v2.5 .. should work OK with Leopard v10.5.6?

Oh, about the complete/new reinstall vs. the repair? I think the original Leopard I purched on CD was v10.2. Apple has recently announced that v10.5.8 is available for download/updating. But here's a problem I haven't yet found a solution to: v10.5.8 is 759MB, more than will fit on a CD. And at my dial-up's speed, I get around 6MB/hr .. let's see: that looks like 126 hours .. 5+days! And that's if Earthlink doesn't drop the connection, which it does every half-hour, or so. Tsk!

dnanian 08-12-2009 10:49 PM

Yes, v2.5 is fully compatible with Leopard.

All versions of Leopard are going to be at least 10.5 - 10.2 was Jaguar. I can't really help regarding your dial-up... :)

BigJim 08-23-2009 04:22 PM

I'm still trying to replace my iMac's 250GB drive (which is about 2/3rds full) with a new 1TB job, using Shirt Pocket's SuperDuper (2.1.4 (v82)) to clone the smaller disk to the larger one.

FIRST ATTEMPT - a couple of weeks ago.

I tried:
1. because it was a brand new HD, before cloning, I used Apple's Disk Utility to format it to a single partition, (Mac OS Extended (Journaled))
2. I used Shirt Pocket's Super Duper to clone the installed disk, through the iMac's USB port, to the external 1TB .. took 6 hours to copy. Although my iMac does have a FireWire port, the new HD does not.
3. Swapped the two HDs, and booted up to the new 1TB.

When the iMac booted up, it got to the user-login screen, and when I selected my profile, these messages came up in a window titled "System extension cannot be used" ... and in successive popups with the same title, these files were identified:


... and to each this message was appended: "... was installed improperly and cannot be used. Please try reinstalling it, or contact the product's vendor for an update."

Since I had a (Time Machine) backup of the original HD from just before the cloning attempt, I tried restoring the listed files to the newly-installed 1TB. When I tried rebooting, just the gray Apple screen, with the ever-turning gear, came up - and went no further .. until it overheated and the cooling turbojet cranked up .. I killed it.

I put the original 250GB back in - boots/runs as usual - and decided to try again a couple of weeks later.

SECOND ATTEMPT - a couple of weeks later (that's this weekend (8/23/2009) ..and during these two weeks, I took my iMac to work to use my company's DSL connection. I was successful in updating Leopard from v10.5.6 to v10.5.8, and got all the other Apple updates (Java, iTunes, etc.) waiting to download to my system done, too.)

I went through all the same preparatory steps, only this time I turned off the Time Machine. The cloning took 1 hour less: 5 hours.

Placing the 1TB in the case, booting it up, the same messages (except 1) reappeared, but this time the list of messages had a couple of new ones:

.. the PPP.kext message didn't appear this time. But in both attempts, I was unsuccessful in establishing a dial-up (PPP) connection.

So, back into the iMac went the 250GB, and that's the one I'm using to compose/dialupconnect/submit this incident to the forum.

I know just 1 other forum contributor has reported this, and his issue resolved itself with a second cloning/replacement attempt. My 2nd attempt didn't do as well.

I am: 20" iMac PowerPC G5 Leopard v10.5.8.

Thanks for your replies/suggs, Dave .. any others? Anyone?

dnanian 08-23-2009 04:53 PM

Well, you certainly shouldn't be using SuperDuper! v2.1.4 to do anything with Leopard, Jim. You should be using v2.5. Have you tried that?

BigJim 08-30-2009 07:46 AM

Missing *.kext files - RESOLVED
Last weekend I downloaded what was then the latest version of SD, v2.5, but had to wait until this weekend to try again. This time the copy did so flawlessly!

THE MORAL, as Dave so patiently pointed out: cloning a Leopard OS requires a SD version somewhat later than v2.1 .. v2.5 did it.

Why was I attempting v2.1? Because it came with a hard drive adapter I purchased from Apricorn about a year ago. Because they supplied SD on a CD, I mistakenly thought it was their (Apricorn's) product. Once I realized it was a trial copy they supplied as a courtesy, and that a later version from Shirt Pocket was needed, and downloaded that, it did the trick.

Thank you, Dave.

dnanian 08-30-2009 08:05 AM

Glad you're all set, Jim.

All times are GMT -4. The time now is 04:10 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.