Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   Scheduler auto-unmount requires admin password. (

D.G. 07-31-2007 04:05 PM

Scheduler auto-unmount requires admin password.
I normally run as a non admin account, and I've noticed that when a scheduled backup runs and the disk wasn't mounted, SD! mounts, does the back up, and then hangs waiting for an admin password to unmount the disk before quitting.

Is there a way around this?

I was imagining if SD! could mount the disk it should be able to unmount it, but I see that using the disk utility app does the same thing, while the finder doesn't require the password to unmount...


dnanian 07-31-2007 04:09 PM

We ask the system to unmount, and for some reason it's not doing it -- perhaps trying to repair permissions?

D.G. 07-31-2007 06:26 PM

I have the feeling it's to do with the process of unmounting that SD! uses combined with not running as an admin.

The prompt I get is from the DiskManagementTool. This is the same prompt as I get from attempting to unmount using the disk utility app:

I can mount from the disk utility, but unmounting from the disk utility asks for an admin password.

On the other hand, if I mount from the disk utility, I can unmount from the finder with no password.

The same thing occurs if I mount just by plugging in the firewire cable. Finder can unmount, disk utility requires an admin password to unmount.

Repair permissions and verifying the disks made no difference to this behavior.


dnanian 07-31-2007 11:51 PM

Unfortunately, I don't think there's anything we can do, DG...

D.G. 08-01-2007 10:30 AM

Would I be correct in thinking that creating the schedule as my admin user should get around this? But then the admin would have to be logged in?


dnanian 08-01-2007 12:56 PM

It depends what's not working on your system, DG, but I'd expect so.

D.G. 08-01-2007 05:09 PM

It seems that either a reboot fixed it, or it was being caused by an issue with the "ignore permissions" options in OS X. Seems to be working fine now (as part of fixing the later I rebooted, so it's hard to tell which actually fixed this).


dnanian 08-01-2007 05:14 PM

Ah, so you didn't restart after the permission repair -- I'm sorry I wasn't more explicit there. Glad that worked.

All times are GMT -4. The time now is 07:47 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.