Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   Failure creating ASR compliant DMG in 10.2.8 (

ChetA 09-06-2005 11:38 AM

Failure creating ASR compliant DMG in 10.2.8
I am planning to upgrade my eMac 800Mh Power PC G4 (ver 2.1) to Tiger from OS X 10.2.8. My internal Macintosh HD drive is a 55.89 GB (1K = 1024) with 16.28 GB used. I have an external Firewire hard drive with 3 partitions of 10GB, 20GB and 202GB. I tried to make a "Backup - all files" to a disk image on the largest partition and it failed with the following error:

|10:55:43 PM|Info| Elapsed Time: 36m 26.422s
|10:55:43 PM|Info| (1 task, weight 100)
|10:55:43 PM|Info| File size: 17306919424 bytes, Checksum: CRC32 $F1047198
|10:55:43 PM|Info| Sectors processed: 34318336, 33802577 copied
|10:55:43 PM|Info| Speed: 7.5Mbytes/sec
|10:55:43 PM|Info| Savings: 1.5%
|10:55:43 PM|Info| created: MacHD OS X 10.2 Backup 2.dmg
|10:55:43 PM|Info| ......COMMAND => Pre-scanning /Volumes/Vol3/MacHD Backup 2/MacHD OS X 10.2 Backup 2.dmg to support fast block copy restore
|11:33:20 PM|Info| /usr/bin/hdiutil: detach: "disk2s1" detached successfully.
|11:33:20 PM|Info| /usr/bin/hdiutil: detach: "disk2s2" detached successfully.
|11:33:20 PM|Info| /usr/bin/hdiutil: detach: "disk2" detached successfully.
|11:33:20 PM|Info| asr: unable to unflatten "/Volumes/Vol3/MacHD Backup 2/MacHD OS X 10.2 Backup 2.dmg" - %s.
|11:33:20 PM|Info| asr: unable to write UDIF info into "/Volumes/Vol3/MacHD Backup 2/MacHD OS X 10.2 Backup 2.dmg" - 78. Function not implemented.
|11:33:20 PM|Info| asr: image scan failed - Function not implemented.
|11:33:20 PM|Error| ****FAILED****: result=256 errno=0 (Undefined error: 0)

The disk image that was created takes 16.11GB of disk space. The disk being used still has 140GB of free space even with the disk image in place. The disk image appears to have been created successfully; it mounts in the Finder and I can access it. I have a couple of questions. (I can provide a copy of the entire log of the run by email if that would be of use to you.)

Do you think the problem is related to running 10.2.8 or do you think there is a problem with the copy of 10.2.8 that I am running?

Would it be possible to still restore the system to a disk using disk copy followed by other steps such as blessing the system folders? If so, how does one bless a OS X system folder?

The full log of this run is in the SuperDuper! log 2.txt upload attached to the “Problem getting apps to run on clone volume” posting made this morning.

dnanian 09-06-2005 12:03 PM

This looks to me like your install of Jaguar is damaged, Chet -- almost like you have a mismatched disk imaging framework.

What I'd do, if you need to create an image, is to use a sparse image instead. See this FAQ for more info.

ChetA 09-06-2005 02:20 PM

I will try your suggestion. Thanks.
Thanks for the prompt reply. I will take your advice and try using a sparse image as you suggest.

I really like your program. That's what prompted me to try using a disk image backup as well as a clone. I decided to try to create a second "independent" backup for safety's sake. (Of course, it isn't really independent since both backups are on the same physical device.) But it won't be a big deal if I can't get a second back up anyway.

Thanks again.
Chet Armstrong

dnanian 09-06-2005 02:29 PM

Thanks very much, Chet -- I'm glad you like it, and hope you'll tell some friends, too!

ChetA 09-08-2005 01:46 PM

Manual creation of sparse image worked
Hi Dave,
I tried your suggestion and I was able to create a sparse image backup.

The only trick was that you have to use Disk Copy on OS X 10.2 and you have to set Disk Copy to expert-mode to get to choose the sparse image format. Fortunately we were able to find the method of doing that described on a web site.

Just in case someone else reading the thread needs to do this, you set DiskCopy to expert mode in OS X 10.2 using the Terminal command:

defaults write expert-mode 1

You can exit from expert-mode (if you wish) using the command:

defaults delete expert-mode

Thanks again for you help.
Chet Armstrong

dnanian 09-08-2005 02:19 PM

Ah, interesting. It's been so long since I've been on Jaguar I didn't realize that their Disk Utility didn't provide for this directly.

Thanks for providing your instructions: I hope they benefit other users as well!

All times are GMT -4. The time now is 12:43 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.