Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   PGP from a Safety Clone (

wavenumber 06-17-2004 07:25 AM

PGP from a Safety Clone
I'm not sure this is related to SuperDuper, but it appears so.
I've made a Safety Clone partition of my boot drive using the “shared users and applications” option. It seems to be working fine, with the exception of PGP.
I’m running the commercial version of PGP 8.1, distributed by PGP Corporation. It’s been installed in my main partition, before making the Safety Clone. It runs without problems in the main drive. However, when I boot using the Safety Clone PGP Disk refuses to mount any secure “disks” previously created. It says the software is not properly installed and that I should uninstall and install it again. If I re-boot from the original partition, it works without any problems.
The other PGP functions seem to be working in both the main drive and the Safety Clone, including the creation of new PGP disks. It’s just the mounting of these “disks” that do not work from the Safety Clone.
Has anyone else experienced this type of behavior?
Thanks in advance!

dnanian 06-17-2004 10:10 AM

Hi, wavenumber.

Although I don't have PGP, it's quite possible that it's not resolving the symlink to its install location (if it's stored in /Applications). If so, this is easily resolved by creating a new Safety Clone script with a small modification.

Here's how to do it:

- Create a new copy script.
- In the 'Description' section, put in an appropriate description. You can copy and paste the one from the existing Safety Clone script, modifying as necessary to explain that this script will copy -- not share -- PGP.
- Switch to the include tab.
- Add in the existing Safety clone - share users and applications script
- Switch to the command tab
- Locate, in the boxes below, the PGP install directory under Applications
- Press Add to add it to the list above

(At this point, the volume name should NOT be specified in the table. If it is, double-click the entry and manually edit it so it begins with Applications (no slash).)

- Change the command, in front of the file path, to "Copy".
- Save the script

Now, use that script rather than the 'built-in' one. This will copy PGP rather than share it, and should solve the problem.

Let me know!

wavenumber 06-17-2004 11:23 AM

Incredibly fast reply!!
It seems to be working now! Thanks!!!

As a side note on what might be a glitch, when I chose to create a new script from the menu nothing happened. The editor did not open. I switched to the main drive and tried again, using both the menu and the command key, and the editor would not open. Then I changed the editor in the preferences from the built-in one to Text Edit and the program opened. I closed it, changed the preferences again to the built-in editor and it worked. All is fine now.

dnanian 06-17-2004 11:37 AM

Glad that worked, and happy to be able to assist.

That's a strange problem (the editor) that I haven't heard of before. I'll log it and we'll see if it's something we can reproduce. Thanks for the report.

dnanian 06-17-2004 01:51 PM

(Thanks, also, for your kind review up on Versiontracker -- much appreciated!)

All times are GMT -4. The time now is 06:52 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.