Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   SuperDuper crashes after telling it to copy (

justn 05-04-2010 08:41 PM

SuperDuper crashes after telling it to copy
After I confirm that I want to copy, superduper goes to the next screen and then it crashes without triggering the OS X crash dialog.

I'm running 10.6.3 on a new 2010 MacBook Pro 15" 2.4GHz core i5.

My Backup drive is daisy-chained to another drive which then goes to my MacBook Pro via a firewire 400 to 800 cable. I have used this setup all the time, only without the firewire 400 to 800 cable. However, I do not believe the cable is bad because data can be read and written to the drives.

dnanian 05-04-2010 09:55 PM

Try re-locking and re-unlocking the lock in the main window (and make sure you are running SD! from your startup drive, and not the backup drive -- a common mistake when people launch with Spotlight).

justn 05-05-2010 01:14 PM

Re-locking and re-unlocking made it work. Thanks Dave.

ruftytufty 08-12-2010 06:59 PM

I have the same problem. Spring 2010 MacBook Pro 13" (Core 2 Duo), 10.6.4. Happened 100% of the time, and the lock/unlock fix works.

I couldn't find any sort of crash log in the usual places.

Fortunately, scheduled jobs do run.

dnanian 08-12-2010 08:03 PM

This can happen if you've migrated or copied an unlocked SuperDuper! to another Mac, or if you're running SD! from something other than the startup drive...

rbarkley671 06-30-2011 06:27 PM

Same crashing problem, same solution
I recently "migrated" to a new MB Pro (17" quad core running 10.6.8) and attempted my first backup to an external FW drive. Same problem as described above. Found this in the console

6/30/11 2:00:23 PM authexec[24741] executing /Applications Added/SuperDuper/SuperDuper!.app/Contents/MacOS/SDAgent
6/30/11 2:00:27 PM SuperDuper![24660] ***ERROR OCCURRED: SDAgent 24741 is not running as root.
6/30/11 2:00:27 PM SuperDuper![24660] ***ERROR OCCURRED: ****FAILED****: result=256 errno=22 (Unknown error: 0)
6/30/11 2:00:27 PM[109] ([0x0-0xa10a1].com.blacey.SuperDuper![24660]) Exited abnormally: Broken pipe

Every time I tried to run. I had the padlock locked so I had to enter my PW. In the activity monitor I could find no "SDAgent. I saw this this thread and tried unlocking. It's runing fine now! And SDAgent and SDCopy are two processes that weren't there before. Makes sense as they are children of SD and would vanish when it crashes.

So the question is, is it possible to run SD with the padlock closed? If so, how?


dnanian 06-30-2011 06:28 PM

Sure, you can run with the padlock closed. But when you migrated, you did so with the padlock open, and Finder didn't preserve all the attributes of the application. That's why you had to re-lock/unlock, etc.

rbarkley671 06-30-2011 09:20 PM

Thanks for clarifying. That should have been obvious to me but wasn't.

All times are GMT -4. The time now is 07:32 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.