Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   Mavericks (

dnanian 10-22-2013 04:24 PM

Here's a blog post about Mavericks compatibility:

Bruno_08 10-23-2013 04:59 AM

Thank's for the infos !

Pendragon 10-23-2013 06:57 PM

Thanks, Dave. Very informative and quite useful.

Now that I know what to look (out) for, I'll try to be less of a bother.

But do you think it would help to get ahead of the issue by deleting the scheduled backups just prior to installing v2.7.2?

dnanian 10-23-2013 07:08 PM

No, you need to do it after.

sdak 10-24-2013 01:10 AM

Bravo, Dave!

SuperDuper! ROCKS!

I am looking forward to this Update showing up in Auto Update Notification when I Launch SD!


If I see that SD Update, and I am still on Mac OS 10.8.5, not ready to Upgrade to Mavericks, 10.9, would it be better to wait till after I Install Mavericks, and then Install this SD Upgrade, or does it not matter?

dnanian 10-24-2013 06:41 AM

The update is compatible with 10.6 and later. So, it doesn't matter if you update before or after Mavericks.

macWish 10-28-2013 11:31 AM


Originally Posted by dnanian (Post 32512)
Here's a blog post about Mavericks compatibility:

I can't get SuperDuper! to do scheduled backups with Mavericks installed even after deleting all scheduled backups, quitting SuperDuper!, then launching SD again and re-scheduling backups. Any other suggestions for avoiding problem with Mavericks and CopyJob?

I hope 2.7.2 is available soon.

dnanian 10-28-2013 12:39 PM

What, exactly, happens?

macWish 10-28-2013 01:25 PM

The copy job failed dialog box comes up at the time schedule for backup and SD fails to launch.

dnanian 10-28-2013 01:34 PM

Did you deny it the ability to run when prompted (or when it asked for security OKs)?

macWish 10-28-2013 02:15 PM

My mistake. My previously scheduled backups were all scheduled to take place at 10 PM - and the next morning, the Copy Job dialog was no longer present. I just scheduled a backup for 2:10 PM and the Copy Job dialog appeared on schedule and when I clicked ok, SuperDuper! launched and performed the scheduled backup. I guess the Copy Job dialog quits on its own if OK is not clicked in a reasonable time period which is why SD did not perform the backups. I will reschedule back up for the day time.

dnanian 10-28-2013 02:17 PM

OK. Let me know what happens.

macWish 10-29-2013 08:10 AM

I deleted my scheduled backups, quit SD, relaunched SD, re-entered scheduled backups, and now the backups are occurring and the Copy Job dialog box no longer appears. Most mysterious.

Could all of the problems with SD and Mavericks and Copy Job be related to the change in accessibility preferences in Mavericks? That is, the need to give control of the computer via Accessibility on Privacy Panel of Security and Privacy Preferences in System Preferences?

dnanian 10-29-2013 08:22 AM

It shouldn't. Copy Job - as I explain in the blog post - asks whether SuperDuper! (and Growl) are running by using a pretty standard Applescript call - "exists process 'SuperDuper!'".

Doing that now flags the process as trying to "control the computer with the Accessibility API" which, of course, is entirely wrong. We're simply trying to determine if those applications are running (eg no sense sending a Growl notification if Growl's not running).

If you don't "OK" Copy Job in the Accessibility part of the security and privacy preference pane (it appears as "applet" in the list, due to a Mavericks bug, even though it appears as "Copy Job" in the panel), you'll get errors.

macWish 10-29-2013 08:48 AM

Not knowing what it was, I did not have "applet" checked on the Accessibility portion of Privacy Panel, which may be why I was getting inconsistent results with scheduled backups. I will let you know what happens now that I have it checked.

macWish 10-30-2013 09:16 AM

With the "applet" checked, two CopyJob failure dialogs promptly appeared when SuperDuper! launched at the scheduled time. However, when I clicked the OK button, SD! promptly quit. So I did a manually copy.

dnanian 10-30-2013 09:19 AM

What exact failure? It sounds like you may need to wait for 2.7.2...

macWish 10-30-2013 11:10 AM

The failure was that after clicking OK on the CopyJob error dialog, that window disappeared and SD! quit without having done anything. I will wait for 2.7.2.

dnanian 10-30-2013 11:19 AM

But it runs normally (manual copies)?

macWish 10-30-2013 01:23 PM

Manual copies run without a hitch.

dnanian 10-30-2013 01:26 PM

I have no idea why this would just quit. Let's move to email so I can get some other information. You know the drill.

Aelver 11-18-2013 04:19 AM

SMB2 sparsebundle?
Will SuperDuper! be able to create sparsebundles over SMB2, or is this the same Apple limitation placed on TimeMachine (AFP only)?

dnanian 11-18-2013 07:09 AM

Same limitation. Use a sparse image.

knutsen 12-08-2013 10:57 PM

Thanks for today's blog update, Dave.

TimLawson 12-11-2013 02:03 PM

Hi Dave - I wondered if you're close to a 2.7.2 release? It's been a while since your last blog entry on the matter...


dnanian 12-11-2013 02:18 PM

Really? I updated the blog a day or so ago.

Spyder 01-06-2014 03:56 PM

After years of scheduled SD use this week I decided to switch to running when I connect the drive. And of course it doesn't work :)

Is 2.7.2 due soon? I'm not affected by either of the issues in your December blog post, I'd be happy to run a beta with those problems.

dnanian 01-06-2014 04:03 PM

This does work in Mavericks, even with 2.7.1, so perhaps you should write me at the support email, Spyder.

Spyder 01-07-2014 04:44 PM

ohh right I misread the blog post. I'll fire an email off when I get home and can grab some console logs when I plug the drive in.

todivefor 01-13-2014 08:47 AM

I had a problem this past week with SD 2.7.1 on Mavericks (10.9.1). I have been using SD since Leopard with no problems. I wanted to do a clean install of Mavericks to see if it would speed up my 2012 Macbook Pro. Although I am using TM for backup, I have more trust in SD when I might have to do a full restore. I did a "backup - all files" to an external USB, which ran with no problem. I booted the newly created back to be sure it was OK. I did my clean install of Mavericks, which did not have my hoped for result, so I decided to restore. After the restore, I saw a couple inconsistencies. In System Preferences, "Internet Accounts" was missing. Also in email, the "load images" button was missing when viewing a message with images. It didn't matter if auto load remote images was checked in preferences or not. At this point, I did a painful TM restore. All is normal now. I can't explain.

dnanian 01-13-2014 08:48 AM

And the backup itself was fine?

dnanian 01-13-2014 08:51 AM

To expand on this - we've done an awful lot of testing on Mavericks, both before and after its release - and I've never seen anything like this (not just on Mavericks, but on any other release). It sounds like the files are there.

When you did the restore, did you erase the volume and restore, or did you try to restore over the existing "clean" install with Smart Update?

todivefor 01-14-2014 11:29 AM

3 Attachment(s)
I thought the backup was fine, but I must have been moving too fast. I just booted the external USB once again and it shows the same thing. See attachments. I then noticed that something was crashing repeatedly. I have attached the log. It looks to me like the restore worked, but the backup is bad. This external had a ML backup on it prior to my Mavericks backup. I did a copy all files which should have erased the ML backup. I looked to see if I had the SD log, but in all the backing up and restoring, it got lost in the shuffle. It looks to me like the backup did a smart backup instead of an erase. I can not rule out user error. I'll try the backup again, but before I overwrite what I have, is there anything you would like me to do?

dnanian 01-14-2014 11:32 AM

Have you tried booting in "Safe Boot" (Shift from power on to the desktop) to see if that helps?

todivefor 01-14-2014 12:41 PM

I tried "safe mode", same result. I just noticed in playing with SD, I had lost my registration. I dug out the info and re-registered my copy. Could operating with an unregistered copy cause this?

dnanian 01-14-2014 02:54 PM

No, we would never create a weird copy if you were unregistered. I'm trying to reproduce what you're seeing here, and I'm completely unable to so far.

It almost looks like the OS was damaged on the original drive, but that damage was masked by caching or something. We copied what was there, and since it had to rebuild the caches, the problem was exposed.

todivefor 01-15-2014 05:41 PM

I did another SD backup on the same system that I had restored with TM. My external USB appears to boot just fine and everything appears to be as should be. Sure can't explain other result.

dnanian 01-15-2014 07:43 PM

Me neither. Really weird - but, seriously. File systems go wonk. Things can happen. It's great to have multiple backups and to use multiple methods, as I've written many times.

I wish I understood what, exactly, happened here - obviously, if it's our fault, I'd love to fix it. But I don't know what the problem could be. Still trying to reproduce without success (which is obviously both fortunate and unfortunate).

Anyway, for others following along, it's always good to have lots of backups. As I've said, SuperDuper! Is a great complement to Time Machine... and if something goes wrong with one or the other, it's unlikely to go wrong with both.

Disk space is cheap... make use of that, and protect yourself as much as is sensible.

TimLawson 02-13-2014 02:14 PM

Any news on 2.7.2 please Dave? Long time no blog post...

dnanian 02-13-2014 02:15 PM

So close...storm's throwing a wrench into things, since I don't want to release when I might lose power and not be able to reply to people...

All times are GMT -4. The time now is 02:41 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.