Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   backup failing (

branman 11-30-2005 09:22 PM

backup failing

Have tried twice to backup with new version 2.0.1. Worked fine on my powerbook, but on ibook it has failed two times. The following is truncated from the log file:

Scripts/Standard Scripts/Backup - all files.dset
| 06:02:44 PM | Info | /
| 06:02:47 PM | Info | /bin
| 06:02:47 PM | Info | /usr
| 06:03:41 PM | Info | WARNING: Caught I/O exception(14): Bad address
| 06:03:41 PM | Info | WARNING: Source: /usr/bin/apply, lstat(): 0
| 06:03:41 PM | Info | WARNING: Target: /Volumes/L/usr/bin/apply, lstat(): 0
| 06:03:41 PM | Info | Attempting to copy file using copyfile().
| 06:04:07 PM | Info | Attempting to copy file using ditto.
| 06:04:33 PM | Error | ditto: /usr/bin/./apply: Input/output error

Any ideas?


dnanian 11-30-2005 09:36 PM

Sure, Brannon. Did you check out the "Troubleshooting" section of the User's Guide?

The implication here is that the file is bad, but it could be a repairable problem. Please boot from your Tiger DVD and use Disk Utility (accessible in the Installer menu) to repair the drive. Then, give the backup another try... and check out the steps in the Guide, which should help.

branman 12-01-2005 02:48 AM

I ran disk utility on the source and destination drives-no problems found. Also disabled anti-virus. Still no luck.

Thanks in advance.

dnanian 12-01-2005 10:06 AM

OK. Do you have any other devices attached to your FireWire bus, such as an iSight? If so, disconnect everything but the drive and see if that works.

If not, it's quite possible that this file is, indeed, damaged. Since it's a system file, it's a bit harder to repair than others, because you can't just delete it. Do you, perhaps, have another computer you can copy it from?

branman 12-01-2005 10:50 AM

Nothing else attached to computer other than power cord. I'll try copying the file from another computer. Should I copy the whole bin folder? Do you know if it is a machine-specific file?

Thanks again for all of your assistance.

dnanian 12-01-2005 10:51 AM

Don't copy the bin folder! It's critical stuff. Just take the single file listed and replace it...

branman 12-07-2005 11:32 AM

Still having difficulties. Seems that many files on the iBook are corrupted somehow. Though the system seems to run fine, I have been unsuccessful using SuperDuper to do a full backup, as well as an attempt at user files only. Additionally, I have tried using Disk Utility to do a 'restore' backup-it also failed. Finally, attempted to backup user files by simply dragging to firewire drive-still failed.

I've run a virus scan, and nothing was detected. The files that are apparently corrupted range from system files to mp3's to pdf's. Has anyone seen this sort of apparently system-wide files corruption?

I'd like to format the drive and reinstall OSX, but can't seem to backup any files before doing that. Obviously I don't want to lose everything in the process.


dnanian 12-07-2005 11:35 AM

If none of the methods you're using to back up are working, but your system is running fine (including the user files you've got that indicate a problem while backing up), it's possible that you've got a FireWire problem rather than a problem on the source disk.

Can you copy the user files that are failing *locally* (that is, duplicate them with Finder)?

branman 12-08-2005 12:11 AM

No-fails when trying to burn a cd or copy within the finder. For example, attempted to copy Pictures and Music folders to the desktop. Got the following:

"The Finder cannot complete the operation because some data in "(filename)" could not be read or written. (Error code -36)."

When attempting to burn a cd, was given Error Code -43.

These issues seem to span many, many files on the computer.

dnanian 12-08-2005 07:54 AM

It certainly sounds like the source volume is severely damaged...

chris hainstock 12-20-2005 05:09 AM

what was the outcome?
reading this thread I just wondered what the outcome was - did you get superduper to work at all.

I am having similar problems with i/o error messages halting SD during backup.

dnanian 12-20-2005 07:48 AM

This wasn't a matter of getting SuperDuper to work, as such, Chris. His drive was damaged -- we can't copy files that can't be copied due to disk damage, but the Troubleshooting section of the User's Guide gives you the steps to try to see if the files are OK on the source.

Dusky 12-24-2005 03:18 PM


Originally Posted by chris hainstock
I am having similar problems with i/o error messages halting SD during backup.

I was having the same problems. I tried the following things to no avail:


The first thing to try is to take this file and duplicate it in the Finder. If it duplicates successfully, delete the original, rename the copy and try the backup again.

If you get an error, the file is damaged beyond recovery and likely has to be re-ripped from the original CD.

If, after this, the backup doesn't work, it's possible that you're getting bus interference on FireWire -- if you have any other devices attached to the FireWire bus, try disconnecting all but the backup drive.
I ran disk utility to check/repair the hard disk, but no problems were ever found. In addition, the S.M.A.R.T status indicated that the disk was fine ("verified"). I ran TechTools (included with my AppleCare plan) and it found errors ("Surface Scan" test). I backed up all the files that could be backed up (to a large extent, this was a manual thing) and took my PowerBook to an Applestore. When the Genius opened Disk Utility, the hard disk's name had changed colors: all red. It was time to have the hard disk replaced. The cost: about 400 bucks, but it turned out to be free thanks to AppleCare. I was told that it'd be ready in five days, or I could have it expedited (next day) for about 100 bucks. I declined the offer and went the standard route. Fortunately, it was ready within six hours.

One thing to note: it started one with one file being unreadable/unwriteable. The file played fine, but I could not make copies of it, not even within the folder. Soon the list of corrupted files grew. Approximately four days transpired between my suspecting a problem with my hard disk and its actual failure.

Had I had the paid version of SuperDuper and a clone of my two hard disk partitions, I would have ran SuperDuper's Smart Update. (One of my partitions didn't have a clone.) If a corrupted file would keep SuperDuper from doing a successful back up, I would have erased the corrupted file and tried Smart Updating again ("Erase and copy" would have taken too many attempts and a lot of time would have been wasted). To find the corrupted file, just look on the SuperDuper log. Unfortunately, you'd have to fish one file at a time.

dnanian 12-24-2005 03:22 PM

Sometimes, no question, this can indicate failure of the source drive... thanks for your story!

All times are GMT -4. The time now is 03:28 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.