Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   Cannot Run Ms Office 2004 Apps from Sandbox (

mpkalman 01-25-2005 01:24 AM

Cannot Run Ms Office 2004 Apps from Sandbox

I recently installed MS Office 2004 on my Mac HD partition. I then cloned a Sandbox partition(shared users and Apps). Of the four office apps, namely, Word, Excel, Powerpoint and Entourage, only Entourage will run from Sandbox. When I run office 2004 on my original partition(Mac HD), they all work fine.

I followed your instructions to another user who had problems with Virtual PC and created a new script which copied rather than shared the complete MS Office 2004 folder in the Applications folder. After using this script to reclone, I found identical behavior, Entourage runs, the other apps do not.

Up until now I had been running Microsoft Office X. I have had no problems running all of its apps from Sandbox while being shared.

Any ideas?

Martin Kalman

dnanian 01-25-2005 10:14 AM

Hm! That's strange, Martin -- I use Office 2004 all the time on the Sandbox, and it works just fine for me.

Do you get any errors in the console? What exactly happens when you try to run the applications?

mpkalman 01-25-2005 11:09 AM

Error Report
1 Attachment(s)

Thanks for the prompt reply. When I run the office programs, an error message file is generated by Microsoft Error Reporting. I have attached this report which is named (Microsoft Error report.doc).

Hope this helps,
Martin Kalman

dnanian 01-25-2005 11:24 AM

From that, it looks to me like you have some bad fonts, or a font manager of some sort that's having trouble. Possible?

mpkalman 01-25-2005 11:41 AM

Bad Fonts

You may well be right. However, I have had no prior indication of this. Can you suggest some font software that could analyze/identify/rectify such a problem?

Martin Kalman

dnanian 01-25-2005 11:44 AM

Try starting up FontBook and look for multiple conflicting and/or damaged fonts. You might also want to try deleting the font cache.

bweylock 03-01-2005 01:29 PM

Did you solve this problem? I have exactly the same symptoms.

A bit hard to believe that I suddenly have font problems since I can run Office flawlessly on the original drive.

dnanian 03-01-2005 01:37 PM

Well, give the instructions here a shot and see if you can find anything wrong. I've got Office here and it works fine on both a Safety Clone and the original (and I've only had this one report -- now two -- of an issue)... that doesn't mean there's nothing wrong, it just means I don't know what it is.

bweylock 03-01-2005 01:48 PM

Since I have not ever had a font problem, I don't really know how FontBook works and can find nothing in the help files about using it to identify font problems.

It of course shows duplicate copies of fonts in Sandbox and the original. Is that in itself a problem?

bweylock 03-01-2005 01:51 PM

And, FYI, repairing Sandbox permissions had no effect on the problem (still there).

dnanian 03-01-2005 01:55 PM

Did you install extra fonts in the "system" area, or in your "user" area? If in the "system" area, try moving them to "user" -- that in itself might resolve the issue, since they'll be shared, not copied.

(Don't do this to system fonts -- just the ones *you* added.)

I wouldn't expect repairing permissions to have any effect... so that makes sense.

bweylock 03-01-2005 02:43 PM

I have never installed "extra" fonts - at least not in well over a year.

bweylock 03-01-2005 02:46 PM

Just thought to check the console error log:
2005-03-01 11:44:16.863 Microsoft Error Reporting[18051] CFLog (21): Cannot find executable for CFBundle 0x14af80 </System/Library/PrivateFrameworks/liberty.framework> (not loaded)

Does that suggest anything to you? The same error is generated each time.


dnanian 03-01-2005 02:51 PM

I understand that you haven't installed fonts in over a year, but I'm trying to figure out whether those extra fonts might be the issue... that's why I asked. Moving those locally -- to ~/Library/Fonts -- might help.

Regarding the "liberty.framework", I have no idea what it is. I don't have it on my system, and it might be referring to something that isn't supposed to be there. Hard to tell.

(I assume, BTW, that you've updated to the most recent Office 2004 release?)

bweylock 03-01-2005 03:00 PM

Didn't mean to sound so argumentative, but I have no idea what "extra fonts" might be.

I have not personally installed any fonts per se since mid-2003, and that was one font called Futura.

If fonts were the culprit, would I not have been having trouble prior to this?

Not trying to be stubborn, but what would I do if I wanted to check for "extra" fonts and remove them to the user library?

Yes, absolutely the latest version of everything.

The problem is only with Word, by the way. I didn't check that until just now. Excel and PP run just fine. I deleted the plist for Word with no help.

All times are GMT -4. The time now is 09:44 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.