Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   OS 9 Boot Caution (

BudSimrin 12-22-2004 12:11 AM

OS 9 Boot Caution
Here is something you might want to consider, or else you can correct my misunderstanding if that is the case. I bought a new large capacity Hitachi hard drive for both Sandbox and to keep multiple backups. Apparently OS 9 requires disk drivers, and I am thinking that SuperDuper cloned or copied the drivers I have for Macintosh HD (which is, I believe, a Seagate drive). Unfortunately, when I try to boot into an OS 9 partition on the Hitachi (either Sandbox or any of the copies) using the Startup Disk Preferences panel, my Macintosh becomes unbootable. When I boot I only get as far as a 3.5" disk image with a flashing question mark. The problem is so bad that I can't reboot from bootable CDs, not even the OS 9 and OS X system CDs (except the OS 9 Tools CD does boot but doesn't allow you to change startup drives), option-boot doesn't work, nor does single user mode. To make my computer usable again I had to boot into Open Firmware, and even then it took several tries to find the sequence of commands that got me back.

I may be wrong that having Seagate OS 9 drivers on an Hitachi drive is the source of the problem (maybe the drivers are disk-independent?), but I believe it may be because one of the error messages I got was along those lines and also the fact that the only OS 9 partition I can now boot from is Macintosh HD.


dnanian 12-22-2004 10:17 AM


If you're creating an OS9 bootable drive, you need to erase it with Disk Utility and tell DU to install OS9 drivers. (The drivers aren't copied, because they're 'outside' the file system.)

Then, update the drive with Smart Update rather than erase then copy.

Hope that helps!

BudSimrin 12-24-2004 10:02 AM

I erased the hard drive and started over just as outlined, but same result--all partitions (including Sandbox as well as normal backup copies) are non-OS 9 bootable. However, I have a 3rd hard drive (Maxtor) for which this worked. In fact, on that hard drive I used Erase Then Copy yet it is OS 9-bootable. Could the Hitachi drive somehow be non-Mac OS 9 compatible?

Also, I found an easier way back from the dreaded 3.5" disk image with a blinking question mark: Just hold down X (for OS 10) while booting. That forces an automatic reboot which then boots from OS 10 on the parition from which I was trying to boot OS 9.


dnanian 12-24-2004 10:07 AM

It's quite possible that the new Hitachi is, indeed, not compatible with OS9. The only way to know for sure is to install OS9 for it 'for real', rather than by cloning... but since they haven't exactly been going all out to write OS9 drivers for new hardware (understatement :)), I think guessing that it's not going to work might unfortunately be accurate.

Good tip re: "x" boot. Note that this will choose the first available OSX bootable drive: be aware that this might not necessarily be the one you want! Holding down Option will give a bit more selection, should that be something you need.

BudSimrin 12-24-2004 10:21 AM

Thanks for the confirmation. I'll just keep the Maxtor around as my OS 9 safety valve. One bootable OS 9 drive ought to be enough.

As for option boot, as I mentioned earlier in this thread, it doesn't work in this situation. Almost nothing works. The only 2 outlets I have found are Open Firmware boot (option-command-O-F) and X boot. OS 9 CDs (lots of them) won't boot nor single user mode (option-S) and other techniques.

dnanian 12-24-2004 10:37 AM

I guess I don't quite see how Option boot doesn't work! It should display all bootable volumes... but maybe it's not available on the machine you're working with. Strange, since I thought it was added when Apple moved to OF.

Well, as long as you can get booted!

BudSimrin 12-24-2004 02:24 PM

Sorry to be unclear. Option boot, single user mode, booting from CDs ... all are NORMALLY available on my computer. But, when I use Startup Disk Preference Pane to select OS 9.2.2. on a Hitachi partition, Mac OS gets so confused that it only gets as far as the flashing question mark, and Option-reboot and all of the other methods fail. They all end up back at the flashing question mark. The only modes that get past the flashing question mark are X-boot and Open Framework boot.

Since obviously the Hitachi partitions can't boot OS 9, it would be nice if Apple would fix the Startup Disk preference pane to not list them, but it does and that's when I get stuck. Since you cannot reproduce this yourself (since you probably have OS 9-bootable drives), I thought I would alert you so you can consider whether this is worth a caution in your docs.

Does this clarify what I mean when I say that Option boot doesn't work?


dnanian 12-24-2004 02:44 PM

Well, that's what I thought you meant in the first place! What's strange is that, as far as I know, Option key handling is done by Open Firmware. As such, I don't understand why Option boot wouldn't work while Cmd-Options-O-F or X would work, since all these keystrokes should be handled by OF's boot loader in ROM, without regard for what the drive situation is.

No matter, though -- as I said, happy you've got a workaround and an explanation.

All times are GMT -4. The time now is 03:36 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.