Shirt Pocket Discussions

Shirt Pocket Discussions (https://www.shirt-pocket.com/forums/index.php)
-   General (https://www.shirt-pocket.com/forums/forumdisplay.php?f=6)
-   -   S.D. always fails with Mac OS 10.4.8 (https://www.shirt-pocket.com/forums/showthread.php?t=1715)

dnanian 10-29-2006 09:05 AM

OK, thanks. This really seems to be a general problem in 10.4.8. It's hitting us along with other applications.

If this is happening to you, I strongly suggest sticking with 10.4.7 until Apple addresses the issue.

sfm 10-29-2006 09:05 AM

Reinstall of OSX doesn't help (completed post)
 
MacBook 2GhZ; 2 GB RAM, purchased 3 weeks ago.

MacBook came with OSX v10.4.6. SD v2.1.3 worked fine.
Apple Software Update (ASU) to v10.4.7. SD v2.1.3 worked fine.
ASU JSE and Quicktime. SD v2.1.3 works fine.
ASU to v10.4.8. SD v2.1.3 no longer works - crashes SD itself, with crash report, and/or crashes all the way back to the finder login, with no crash report.
(also had similar crashes of TextEdit and Microsoft Office Word 2004 (with latest updates.))
Reported to Shirt Pocket and Apple (they didn't seem to like it much that both one of their apps and a Microsoft app also crashed, probably because it points toward an Apple problem.)
Did all the Apple suggestions (PMMU etc. etc.), and also deleted SD preferences and downloaded another SD copy. SD still crashes.

Archive and reinstall v10.4.6.
ASU to v10.4.7.
ASU JSE and Quicktime. SD v2.1.3 works.

ASU fan firmware update.
Combo update to v10.4.8. SD v2.1.3 crashes again.

Archive and reinstall v10.4.6.
Delete previous system folder.
Combo update directly to v10.4.8. SD v2.1.3 crashes again, although it makes it 99% of the way through a full backup before crashing, the farthest so far.
ASU JSE and Quicktime. SD v2.1.3 still crashes.

Archive and reinstall v10.4.6 again.
Delete previous system folder.
ASU JSE and Quicktime.
Combo update to v10.4.7. SD v2.1.3 works again.

(I also tried backing up using a USB connection to my external backup hard drive, instead of my normal firewire connection. No change - SD still crashes.)


I'll stop fiddling now...


I observed one thing that may or may not be helpful to diagnose this issue further:

1. I have multiple hard drives that I backup to. After discovering that I needed to partition using the GUID format, not the APM format, to make a bootable Intel backup, I did that. I have noticed that the original names that I give to the partition that I'm attempting to backup to are usually CHANGED after the attempted backup. A space and the number 1 is added to the end of that partition name, - the changed name is visible in the SD drive list, and in the Disk Utility partition list on the left, but NOT in the Disk Utility partition name when I go to the partition tab, and NOT in the finder. Weird.

Also, if you have multiple computers and hard drives, I discovered that I can make a backup of the MacBook with OSX v10.4.8 installed using SD v2.1.3 on another computer, in this kludged way:

Start up from one of my other PowerBooks, with OSX v10.4.8.
Connect to the MacBook (with OSX v10.4.8) in the firewire target disk mode.
Chain a backup hard drive with another firewire cable.
Use SD v2.1.3 and select the firewire target mode MacBook as the backup source, and the backup firewire hard drive as the destination.
Backup completes, although more slowly than when doing it directly from the source MacBook drive itself (with OSX v10.4.7, since SD 2.1.3 crashes with v10.4.8 on the MacBook, as described above.)

dnanian 10-29-2006 09:08 AM

Thanks for the additional information. As I said above, this pretty much confirms what I feared: 10.4.8 has a bug, and -- unfortunately -- its intermittent nature causes some "mystery" fixes (like a combo update application) to "look" like it works, but it doesn't.

The only fix for this at present is to go back to 10.4.7. We've got some ways to "shrink the window" where the bug happens (which has to do with screen updates), which should help to minimize the effect. But we can only do so much, alas.

adam78 11-05-2006 04:34 AM

I think I'm having the same problem. Macbook Pro, 10.4.8. SuperDuper previously worked well backing up to an external Firewire drive when I was running 10.4.7. Now the backup gets about 60-70% through (according to progress bar) and perhaps more (according to the count of the files analysed), and stalls. My CPU usage goes through the roof and practically locks up my system. :( Just wanted to let you know.

dnanian 11-05-2006 10:18 AM

No, that's an entirely different problem, actually. Open the Activity Monitor and look to see what's taking all the CPU when things have trouble...

Vince-from fr 11-05-2006 11:26 AM

Did some tried my little solution : to start with all extensions deactivated ? It worked for me.

maccaa 11-06-2006 07:52 AM

?
 
Hi Vince,

Can you explain how do you disable extensions?

Maccaa

MacVmUser 11-06-2006 12:46 PM

Is problem resolved?
 
Quote:

Originally Posted by Vince-from fr (Post 9204)
Did some tried my little solution : to start with all extensions deactivated ? It worked for me.

I'd also like to know if this is a valid workaround.

Beyond that, has Apple resolved this issue yet? Is it now safe to update to 10.4.8... or should we stay with 10.4.7 to ensure continued operation of S.D. on intel-based Macs?

Thanks for this thread!

dnanian 11-06-2006 12:47 PM

This has not been resolved. Please stick with 10.4.7 for now: it's the surest "workaround"...

jivan 11-07-2006 01:54 PM

Quote:

Originally Posted by dnanian (Post 9054)
This is an entirely different issue, jivan. If your RAID is munged and is failing strangely, you're having a hardware problem with the drive... anything else on FireWire?

Sorry for the delayed reply. I think it's the same issue. The munged RAID only occurred once, but I think it was caused by having to hot restart the drive to get it to reappear after my iMac hung. Maybe it was still being written to at the time. I'm having the same problems as everyone else on this thread. No more problems with munged RAID, but consistent hangs.

No other items on the FW bus.

FWIW, I'm getting hangs with Carbon Copy Cloner as well. Hope a fix comes in from Apple (or you guys find a workaround). The only working backup solution seems to be Apple's and that's a lousy one.

Thx.

crooner 11-09-2006 07:09 PM

Quote:

Originally Posted by dnanian (Post 9115)
<snip>
Unless we come up with something brilliant, it looks like we're going to have to wait for Apple to fix this bug.

Wait a minute. Unless? UNLESS?!? Dave, it's your purpose to come up with something brilliant on a regular basis. I'd say, off the top of my head, you should be coming up with at least one brilliant idea every 36 hours. Anything less and my confidence will be shattered.

I'm too upset to even talk now...

;)
:D :D :D :D :D

crooner - the singing geek

crooner 11-09-2006 07:38 PM

Okay, wise-ass mode officially off.

From what everyone seems to be saying, am I safe in assuming that this issue does not occur on PPC systems running 10.4.8?

(I actually still haven't updated to .8. I've heard of other oddities regarding its installation and am holding out.)

BTW, what Dave mentioned earlier as a possible/worth a try solution regarding using the Combo Updater reminded me to put in my 2˘... ALWAYS download and use the combo updater from Apple. Never (if at all possible) let Software Update just do it for you. Maybe I'm paranoid or overly cautious, but regularly advising about 15 friends on what to do when their Macs get funky I usually find that they let Software Update run rampant like a streaker at a soccer game.

And while we're here, let me shed a little sunshine on Dave and SuperDuper!

I came across a blog on the 'net that was linked from one of today's articles on MacFixIt:

http://blog.plasticsfuture.org/2006/...tware-harmful/

This article (the blog) essentially is a thorough, independent test of what looks like all of the available GUI driven backup solutions for the Mac. They are rated from Highly Recommended to Avoid At All Cost.

ONE title was given the highly coveted "Highly Recommended" recommendation (along with a side note that it does everything right and nothing it shouldn’t do).

And that software was... Mitch Cummstien, my college roommate...
Sorry, had a Chevy Chase/CaddyShack flashback there for a second.

And that software was SD! No other software scored as high. So keep swingin' (in every sense of the word), Dave. And don't worry folks... if there's a fix to be found before Apple gets around to it, Dave and the crew at Shirt Pocket will find it.

crooner - the singing geek

dnanian 11-09-2006 07:41 PM

That's right: every report of this we've seen is on Intel Macs running 10.4.8. It doesn't look like the Combo update actually resolves the issue, though.

Thanks for the nice comments. After the recent flood of Version Tracker one-star reviews, it's nice to get something positive! :)

crooner 11-09-2006 09:41 PM

I just left some good feedback on VT.
Your troops won't let you down.

dnanian 11-09-2006 09:48 PM

Jeez, don't consider yourself "troops", people -- that wasn't intended to beg for feedback! :) (But thanks!)


All times are GMT -4. The time now is 11:57 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.