View Full Version : My own include scripts

10-19-2015, 03:58 PM
Is there a way to include my own copy scripts inside of a higher level backup script? I can see that SD allows me to do that, but when I go to run the higher level backup script it complains that the included script can't be found inside the SD.app/Contents/...

I don't want to have to modify the contents of the SD app because I don't want to lose my customizations when I upgrade SD in the future.

so where can I place my own copy scripts which can then be included in other higher level copy scripts? I wish to have several different high level backup scripts that share a common list of excluded files, basically.

10-19-2015, 04:11 PM
I think I might have figured it out, by editing the .dset XML code directly I can put the full path name to

Library/Application Support/Super Duper!/Copy Scripts/myincludescript.dset

which seems to be working. Is there no way to do this in the GUI, only through editing the xml file? When I load the copy script in the GUI it does display the entire path name correctly. seems like if I choose an include script to use with a full path, SD ought to just remember that.

10-19-2015, 04:22 PM
So...the include tab is forcing the path to the standard scripts folder, even though you add it from Copy Scripts (the parent folder)?

10-19-2015, 04:56 PM
In the GUI when I open a copy script and then go to the include tab and then hit the + button, it opens up the file dialog to

~/Library/Application Support/SuperDuper!/Copy Scripts/

I then choose a script and it accepts it, and I see it listed in the list of includes. However when I run the backup I get the following error:

| 01:44:52 PM | Error | SDCopy: Unable to locate included copy script: xyzExcludeAlways.dset in /Applications/SuperDuper!.app/Contents/Resources
| 01:44:52 PM | Error | : No such file or directory

So then I tried to manually edit the dset file so that I can specify more of a full path name. I see that what is there when I configured via the GUI is not the full explicit path name, just the base name, I guess its assuming to find it in Standard Scripts.

So I tried to set it like this with full explicit path name in the dset file directly:

<key>Include Directives</key>
<string>Backup - all files.dset</string>
<string>/Users/xyz/Library/Application Support/SuperDuper!/Copy Scripts/xyzExcludeLists/xyzExcludeAlways.dset</string>

The above appears to work. When I go back to the GUI to view the copy script, it does display the whole explicit path name exactly as contained in the XML.

10-19-2015, 05:00 PM
Interesting. Clearly a bug, I'm sure there since day 1 - I'll get it logged. Thanks.